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Introduction
The SimSphere Modeling Tool is designed to help you understand the relationships between
important natural processes that occur in the soil, plants and atmosphere.
You will use SimSphere to set parameter values for characteristics of soil, plants and atmosphere,
then to run and graph simulations to model different biosphere and atmospheric scenarios. The
exercises in the simulation sections of your textbook give you certain parameter values to simulate specific meteorological conditions. You may want to experiment with parameter settings on
your own to better understand this tool or the phenomena it illustrates.
This documentation will outline what you need to run SimSphere, the tool’s important features,
and the steps required to perform a simulation.
Remember that this is a beta, or preliminary, version of this application, which means that it is
still in development and that some features may not yet be functional. Please report any errors to
your instructor.
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1. SimSphere Modeling Tool Overview
System Requirements
You may download the SimSphere Modeling Tool to run on a local machine as a stand-alone
application, or you may access it on the Web as an applet. At minimum, you will need:
Operating system:

Windows 95/98/NT

Java software:

Java Runtime Environment/Java Plug-In version 1.2.2

Internet connection:

In addition to requiring an Internet connection to use SimSphere online, you will also require one to perform remote exports and imports
from the stand-alone application.

Your User Status
Users will have different levels of access to the import, export and edit features in this tool
depending on their assigned status.
If you do not hold an account, then you can assume that you have standard access to the application.
Use the chart below to check which import/export features will be available to you.
Figure 1. User Status Chart: Import/Export Access

Access Level

Standard

Type of Use
as an applet via Web browser

remote import

as an application on local machine

local import
local export
remote import

as an applet via Web browser

remote import
remote export

as an application on local machine

local import
local export
remote import
remote export

Account Holder
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Available Import/Export Features

SimSphere Overview

Main Menu
File

Use the File menu features to create a new simulation, to import and export data, to close a
simulation, to print parameters, and to close SimSphere.
Parameter

Use the Parameter menu features to set or edit the characteristics associated with time/
location, vegetation, surface, meteorology, wind sounding, moisture sounding, and soils.
Graph

Use the Graph menu features to create graphs of the simulation you have run and to name
and view the graphs that you have created for simulations.
Run

Use the Run menu features to execute simulations and to animate the sounding profiles.
About

Use the About menu features to change the appearance of the SimSphere application interface.

SimSphere Overview
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Toolbar
The toolbar gives you quick access to many of the SimSphere features you will use most frequently. The functions of each feature are described in detail in this documentation.
Figure 2. SimSphere Toolbar
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SimSphere Overview

Workflow Overview
The steps below serve as a general guide for the sequence you will follow to create a new simulation, set parameters, and graph results using SimSphere. The features mentioned in each step
are described in detail in the following chapters of this documentation.
1. Launch SimSphere

You may have the option of running the SimSphere Modeling tool as an applet using a Web
browser, or from a local machine as a stand-alone application.
2. Create a simulation

Choose File > New to create a new simulation.
The Summary window will open.
3. Edit parameter values

• Choose Parameter and select the specific parameter in the drop-down menu whose values
you would like to edit.
Or
• Choose Parameter > Parameter QuickEdit to quickly access all parameters.
4. Run a simulation

Choose Run > Run to run the simulation.
5. Graph results

Choose Graph > New to create a graph.
 Add one or more series to the graph to plot results of the simulation.
6. Animate the sounding profiles

Choose Run > Animate Sounding Profile
7. From this point, you are likely to choose one of the following two steps:

• Make changes in the Parameters
 Choose Parameter then change the settings in the parameter of your choice
• Start a new simulation
 Choose File > Close to end the old simulation. You will be prompted to export
data, or to close the simulation without exporting data.
 Choose File > New

SimSphere Overview
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2. Getting Started
You may choose to download and install SimSphere on a local machine to run as a stand-alone
application, or run the tool on-line as an applet using a Web browser.

Using SimSphere as a Stand-Alone Application
I. Download Tool

1. To install SimSphere as an application on your machine, click the link to download the
program file on the SimSphere home page.
2. You will be prompted to save the file to your machine.
• If you are using Netscape Navigator, choose “Save File” in the Unknown File Type
dialog box.
• If you are using Internet Explorer, click the radio button next to “Save this program
to disk” in the File Download dialog box.
3. Choose or create a folder in which to save the program file named “SimSphere.”
Note: Downloading the tool will take several minutes; you are copying nearly a megabyte of material onto your machine.
II. Install the Tool

1. After the download is complete, open the folder in which you saved the application and
double click the “SimSphere” file icon.
2. On some machines the WinZip Self-Extractor dialog box open (if not, skip to the hint
below). If it does, indicate the location where you want to save the files and click the
“Unzip” button.
Hint:

Make a shortcut to the tool for your desk. This way you won’t have to open the
folder in which the program files are located each time you want to use it.



With the “Startup” file selected, choose File > Create shortcut. Then drag the
shortcut icon to your desktop.

III. Launch the Tool

1. Double click the “Startup” file icon or the shortcut icon you have made for the tool.
The tool will open an MS DOS window, then take a few moments to load. A Welcome
pop-up box will open to show that the application is still loading, then the SimSphere
window will open.
Note: Do not close the MS DOS window. Closing this window will cause the application to shut down.
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Using SimSphere as an Applet
You may also choose to run SimSphere as an applet, a program which runs within your Web
browser from a remote computer. You can run SimSphere as an applet from any Windows workstation that has Internet access and a Web browser with the correct Java plug-in installed.
I. Check Java Plug-in

Check that the Java plug-in v. 1.2.2 needed to run the application as an applet is installed on
the machine you are using.
1. Launch the MS DOS Command Prompt.
 Choose the Windows Start button > Programs > Command Prompt.
 Next to the prompt, type the command “java -version” and press Return. The
Java plug-in version number should display in the line of text that appears, i.e.,
‘Java version “1.2.2”...’
Note: For information about, or to download the plug-in, visit
http://java.sun.com/products/jdk/1.2/jre/.
II. Launch Applet

1. Launch the SimSphere applet in your Web browser by clicking the applet link on the
SimSphere home page.
Note: The tool itself will take several minutes to load onto your local machine; it will
be slower to open when accessed on a machine connected to the Internet by
modem than by one on a local area network (LAN or backbone) connection.
2. A Java Console window will open. You may close this window without affecting the
program. A Welcome pop-up box will appear after a few seconds indicating that the
applet is loading.
Note: Do not close your Web browser or terminate your Internet connection. This will
cause the applet to shut down.

Getting Started
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3. Creating a Simulation
The Summary window is the foundation for every simulation. It displays key pieces of information about the simulation parameters and indicates that a simulation is open. It displays the next
run number, or iteration, of a simulation and (when it first appears) the default settings for Time/
Location, Vegetation, Surface and Meteorological data parameters. It also reflects the latest
changes made to parameter values.

Beginning a Simulation
1. Choose File > New or click the New simulation button on the toolbar.
New Simulation button

The Summary window will appear.
Figure 3. Summary Window

2. You are now ready to edit parameter values. For more information on this step please see
the section Editing Parameters in chapter 3, Creating a Simulation.

Closing a Simulation
1. To close an active simulation choose File > Close, or click the Close Simulation button
on the toolbar.
Close Simulation button

10

Creating a Simulation

Depending on your user status, a dialog box will open which gives you the choice to:
export your parameter data; close your simulation without exporting data; cancel the
export command.
Exporting your data will save the parameter values you have set in a simulation to an
XML file. You will be able to open the file in SimSphere later by importing the data.
Learn about exporting and importing data in chapters 7 and 8.
Note: If you choose not to export the data, all changes in values will be erased.

Editing Parameters
When you create a simulation, the parameter values will be set to SimSphere’s defaults. You
can view or edit individual parameter settings by choosing a particular parameter in the
Parameter drop-down menu, or by selecting the corresponding shortcut button on the toolbar.
Figure 4. Parameter Drop-Down Menu

In edition to editing parameter values, you can view and modify data sets for plants and soils,
winds, and moisture sounding in SimSphere by selecting a specific parameter under the
Parameter menu.
You can access Time/Location, Meteorological, Vegetation, and Surface parameter settings in
one location using the Quick Edit command.
Note: If you change a setting to a new value outside the possible range, a warning will
appear in the message area at the top of the window.

Creating a Simulation
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Time/Location

1. Choose Parameter > Time/Location, or click the Edit time and location
parameters button on the toolbar.
Edit Time and Location Parameters button

The Time/Location dialog box will appear.
2.

Select and make changes to data.

3.

Click OK to save changes.

Vegetation

Use the vegetation data dialog box to edit vegetation parameters, to calculate foliage albedo,
and to determine whether to use the Deardorff or Carlson/Lynn method for parameterization.
1. Choose Parameter > Vegetation, or click the Edit vegetation parameters
button on the toolbar.
Edit Vegetation Parameters button

The Vegetation Parameters dialog box will appear.
2. Select and make changes to data.
3. To choose to calculate foliage albedo, click the Calc. Flg. Alb. checkbox.
4. Choose the method of parameterization by clicking the Deardorff or Carlson/
Lynn radio buttons. These are two different methods for calculating stomatal
resistance.
5. To edit the plant set data, choose Define plants. To learn more about this step,
see the section below on Plant Data.
Surface

Use the surface data dialog box to modify surface parameters and to calculate ground albedo.
1.

Choose Parameter > Surface, or click the Edit surface parameters button on the
toolbar.
Edit Surface Parameters button
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Creating a Simulation

The Surface Parameters dialog box will appear.
2.

Select and make changes to data.

3.

To calculate ground albedo, click the Calc. Gnd. Alb. checkbox.

4.

To edit the soil set data, choose Define soils. To learn more about defining soil
data, see the section below on Soil Data.

Meteorological

1.

Choose Parameter > Meteorological, or click the Edit meteorological
parameters button on the toolbar.
Edit Meteorological Parameters button

The Meteorological Parameters dialog box will appear.
2.

Select and make changes to data.

3.

Click OK or Done to save changes.

Wind Sounding Profile

1.

Choose Parameter > Wind sounding profile, or click the Edit wind sounding
profile button on the toolbar.
Edit Wind Sounding Profile button

The Wind sounding profile dialog box will appear.
Figure 5. Wind Sounding Profile Dialog Box

Creating a Simulation

13

2.

In the Wind sounding profile dialog box, edit direction, speed, and altitude data
by clicking on the value you wish to change.
 Change the value and then select the checkmark () to save the change or the
‘x’ () to cancel the change.

3.

Choose Add/Delete/Import to add, delete or import direction, speed and altitude
data.
• Use Import to import existing local or remote data files. For help with this step
please refer to chapter 8, Importing Parameter Data.

5.

Choose Edit at the bottom of the screen, to edit the Surface Geostrophic Wind
data.

6.

Click Cancel to cancel the changes or OK to accept the changes and continue.

7.

Click Done to accept changes and exit the soil window.

Moisture Sounding Profile

1.

Choose Parameter > Moisture sounding profile, or click the Edit Moisture
sounding profile button on the toolbar.
Edit Moisture Sounding Profile button

The Moisture Sounding Profile dialog box will appear.
2.

In the Moisture Sounding Profile dialog box, edit data by clicking on the value
you wish to change.
 Change the value and then select the checkmark () to save the change or the
‘x’ () to cancel the change.

3.

Choose Add/Delete/Import to add, delete or import moisture data.
• Use Import to import existing local or remote data files. For more help with
this step please refer to chapter 8, Importing Parameter Data.

Figure 6. Moisture Sounding Profile Dialog Box
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Plant Data

1.

You can access plant data in several ways:
• Choose Parameter > Plants.
• Choose Parameter > Vegetation > Define Plants.
• Click the Edit vegetation parameters button on the toolbar.
Edit Vegetation Parameters button

The Plants dialog box will appear.
2.

In the Plants dialog box, select a plant or family of plants in the scrollable list.
The values set for that plant will appear under “view plant parameters.”

3.

Choose New/Edit/Delete/Import to add or import new plants, or make the
changes you wish.
• Use Import to import existing local or remote data files. For more help with
this step please refer to chapter 8, Importing Parameter Data.

4.

Click Cancel to cancel changes or OK to continue.

5.

Click Done to save changes and exit the Plants dialog box.

Soil Data

1.

You can access soil data in several ways:

Creating a Simulation
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•
•
•

Choose Parameter > Soils.
Choose Parameter > Surface > Define Soils.
Click the Edit Surface Parameter button on the toolbar.
Edit Surface Parameters button

The Soil dialog box will appear.
2.

In the Soil dialog box, select a soil in the scrollable box. The values set for that soil
will appear under “view soil parameters.”

3.

Choose New/Edit/Delete/Import and add or import new soils, or make the
changes you wish.
• Use Import to import existing local or remote data files. For more help with
this step please refer to chapter 8, Importing Parameter Data.

4.

Click Cancel to cancel changes or OK to continue.

5.

Click Done to save changes and exit the soil window.

Quick Edit Feature

The Parameter Quick Edit dialog box gives you quick access to the Time/Location, Vegetation, Surface and Meteorological data parameters in one location.
1.

Choose Parameter > Parameter Quick Edit or click the Parameter Quick Edit
button on the toolbar.
Parameter Quick Edit button

The Quick Edit dialog box will appear.
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Figure 7. Parameter Quick Edit Dialog Box

2.

Expand and collapse the folder tree to access different parameter values by clicking on the magnifying glass icon next to a folder, or by double clicking on a folder
itself.

3.

To edit values, click on the white page icon next to the parameter title or on the
title itself.

4.

Change the value and then select the checkmark () to save the change or the ‘x’
() to cancel the change.

Note: If you click to another parameter without selecting the checkmark to accept your
changes they will be lost.
5.

⌧) in the
Exit the Parameter Quick Edit feature by clicking the close button (⌧
upper right corner of the window.

Comparing Parameters

The Parameter Comparison window displays the history of parameter changes from one
simulation run to the next.
1.

Select Parameter > Parameter Comparison or click the Compare Paremeters
button on the tool bar to open the Parameter Comparison Window window.
Compare Parameters button

The Parameter Comparison window will appear.

Creating a Simulation
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Figure 8. Parameter Comparison Window with Multiple Run Values Displayed

2.

View a complete list of parameter value changes by clicking the magnifying glass
“plus” icon. Collapse the list into a general summary of changed parameters, by
clicking the magnifying glass “minus” icon.
 Click the magnifying glass icon next to a parameter to display or hide parameter values for each run number.

3.

Print parameter comparison data by clicking the printer button at the top of the
Parameter comparison window.

Note: For help with printing, please see the section Printing Parameters that follows in
this chapter.
4.

⌧ ) in the
Exit the Parameter Comparison window by clicking the close button (⌧
upper right corner of the window.

Printing Parameters

Use the Print parameter button on the toolbar to print all current simulation parameters. The
parameter report printed by SimSphere includes time/location (overpass), meteorological,
vegetation, surface, current soil and plant parameters, as well as wind and moisture sounding
profiles.
1.

Click the Print parameter button on the toolbar.
Print Parameter button

2.
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Select layout and other format options in the Page Setup dialog box and click OK.

Creating a Simulation

3.

Choose the printer you want to print to from the Name drop-down list of the Print
dialog box and click OK.

Note: For more help with printing, review the printing documentation in Windows
Help.


Go to Start > Help > Contents > How to > Print.

Creating a Simulation
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4. Running Simulations
Running the simulation commands the program to perform simulation calculations based on
parameter values.
Run Simulation

1. Choose Run > Run to run the simulation, or click the Run simulation button in the
toolbar.
Run Simulation button

You may experience a short delay before the Progress pop-up window appears displaying the status of the run.
Hint: The simulation run number, or iteration, displayed in the Summary, Parameter
Comparison and graph windows, gives you a way to keep track of the changes you
make to parameters.
2. Once you have run a simulation, you are ready to graph your results. For help with this
step please see chapter 5, Graphing Results.
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Running Simulations

5. Graphing Results
The graph feature of SimSphere helps you to better understand simulations by giving you a way
to represent results visually. To keep hard or electronic copies of the graphs you create, you may
print or export them.
For help with printing, please see the section Printing Graphs in this chapter. For help with
exporting please see chapter 7, Exporting Parameter Data.

Graphing the Results of a Simulation
You must have run a simulation or imported data to access the Graph menu.
Add Series

1.

Under the Graph pull down menu, select New or click the Create a New Graph
button on the tool bar.
Create a New Graph button

An empty untitled grid will appear.
2.

Click on the Add series button to choose a series to plot from a given list of
variables.
The Add y-series dialog box will appear.

Figure 9. New Graph with Add Y-Series Dialog Box Open

Graphing Results
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3.

Select a series and click on the static or dynamic radio buttons to select the type
of line you wish to plot.
• Static Series
Choosing “static” when you plot a series will give you a fixed line.
•

Dynamic Series
Choosing “dynamic” when you plot a series will give you two lines. You will
see two series names next to black and red line segment icons at the top of the
graph. The title next to the red line segment will be preceded by “[Dyn]”
indicating that it is dynamic. As parameter values that affect the series are
edited and the simulation is run again, this dynamic line will reflect any
changes in parameters which distinguish the results of the newly calculated
simulation from the original path, represented by the black line.

Figure 10. Graph Plotted with a Single Dynamic Series

Note: You may add as many series, static or dynamic, to the graph as you wish, but to
prevent a grid from becoming so crowded that it becomes difficult to interpret,
you may wish to plot your results on several graphs.
Remove Series

1.
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To remove a series once you have added it to a graph, click Remove series at the
top of the graph.

Graphing Results

2.

In the Remove y-series dialog box, select the series you want to delete by clicking
Remove. This removes that series from the graph and closes the Remove y-series
dialog box.

Note: To remove a dynamic series from a graph you must remove two lines in the
Remove y-series dialog box. Select and delete both titles for the series (one will
include a run number).

Modifying the Visual Elements of a Graph
Once you have plotted a graph, you can vary its appearance in a number of ways. To distinguish between multiple series, you can change the color and style of a line.
Line Style

1.

To change line color and style, click on the black (or red if dynamic) line segment
button to the left of the checkbox and series name at the top of the graph window.

2.

Pick a new line color from the swatches palette by clicking on the color square of
your choice.

Figure 11. Swatches Palette Selected in the Line Style and ColorChooser Window

3. Pick a new line style by clicking in the check box next to the style of your choice under
“choose a line style.”

Graphing Results
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Note: Clicking on the HSB and RGB tabs opens palettes that give you two additional
ways to change the color of your graph. HSB allows you to alter the values of
Hue, Saturation and Brightness. RGB allows you to alter the intensity of the
colors red, green and blue.
Show/Hide Lines

Click in the checkbox next to the series title at the top of the graph to show and
hide series.
Points and Grids

1.

Click the Points checkbox at the bottom of the screen to show and hide the plotting points along a line.

2.

Click the Grid checkbox at the bottom of the screen to show and hide the graph
grid.

Managing Graphs
Use the Graph manager feature to create new graphs, delete old graphs, and show, hide and
rename current graphs.
1. Choose Graph > Graph manager.
The Graph manager window will appear.
Figure 12. Graph Manager Window

2. Create, delete, hide, or rename graphs
• To Create a new graph, click New.
• To Delete a graph, select it and click Delete.
• To Show or Hide a graph, select it and click either Show or Hide.
Note: Hiding a graph will not delete it.
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• To Name or Rename a graph, highlight it and click on Rename.
Replace the current name in the Rename pop-up window with the new name, and
click OK.
3. Click Done to close the Graph manager and accept your changes.

Saving Graphs
To save graphs, you will need to perform a local or remote export. For help with this step
please see chapter 7, Exporting Parameter Data.
Hint: To save a file containing only graph data, click the “Graphs only” radio button in the
Parameter Options dialog box.

Opening (Importing) Graphs
If you have saved (exported) graphs, you can open them by performing a local or remote
import from the location where they are saved. Your import options will be determined by
your user status. For help with that step, please see chapter 8, Importing Parameter Data.
Note: Once you have imported a file that includes graph data, the Graph manager will
appear displaying the graph(s) saved in the file.

Printing Graphs
1. To print a graph, click Print.
Note: Applet users click Yes in the pop-up Warning window to confirm that you would
like to print.
2. Choose the printer you want to print to from the Name drop-down list of the Print dialog
box and click OK.
Note: For more help with printing, review the printing documentation in Windows
Help.


Graphing Results

Go to Start > Help > Contents > How to > Print.
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6. Animating Sounding Profiles
Animating the sounding profiles is another means of helping you to visualize and interpret
results. The animation shows how the vertical profiles of wind speed, wind direction, humidity
and temperature evolve over time

Running an Animation
1. Choose Run > Animate Sounding Profile or click the Animate sounding profiles
button on the toolbar.
Animate Sounding Profiles button

The Sounding Profile Animation window will appear.
Figure 13. Sounding Profile Animation Window

2. Use the buttons in the Sounding profile animation window like those on a tape recorder
• Either click the Play button to animate the profile data, or drag the slider on the
progress bar to a specific point.
• Click Stop to stop the animation.
• Click Rewind to move back to the beginning of the animation
• Click FFwd to skip to the end of the animation.
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Animate Sounding Profiles

• To skip to a specific point in the animation, drag the slider on the progress bar.
Hint: Enlarge the window for best display of the animation by clicking on the maximize
button in the upper right hand side of the window.
Note: You can modify the appearance of the sounding profile animation as you would the
graphs in SimSphere. For help with this step please see the section Modifying the
Visual Elements of Your Graph in chapter 5, Graphing Results.

Printing Sounding Animation Frames
To print frames of the sounding profile animation, follow these steps.
1. Stop the animation at the frame you would like to print, or drag the slider on the progress
bar to that point.
2. Press Print Screen on your keyboard.
3. Paste into a graphics application, i.e., Microsoft Paint or Adobe Photoshop.
• MS Paint is a simple graphics application included in most Windows packages.
To open it, go to Start > Programs > Accessories > Paint.
4. Save the file if you wish and print.

Animate Sounding Profiles
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7. Exporting Parameter Data
Export parameter data to save some or all of the values you have set for a simulation. The parameter data will be saved as an XML file, which you will be able to open (import) later in SimSphere to recreate a specific simulation.
You can export parameter data at anytime while you are working in a simulation by accessing the
export data commands under the File menu. You will be prompted to export data by SimSphere
when you close a simulation or create a new one without exiting the existing summary window.
Note:

If you choose not to export your data, any values that you have set for that simulation
will be cleared from the tool permanently.

Note:

Your options for exporting data will be determined by your user status and whether
you are accessing the tool as a stand-alone application or as an applet. Menu or
toolbar items for which you do not have access with be grayed out.



The notes that follow this computer symbol in the instructions below indicate the
users who have permission to access the SimSphere commands or features described.

Exporting to a Local Drive

 For Standard Users and Account Holders working on a stand-alone copy of SimSphere.
1. Choose File > Local Export or click the Local Export button on the toolbar.
Local Export button

The Export dialog box will appear.
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Exporting Data

Figure 14. Export Dialog Box

2. Click on the Look in drop-down list in the Export dialog box to choose the drive on
which you want to save your file.
3. Click on the Options button to define the parameter data that you want to export. The
Parameter Data Options dialog box will appear.
Figure 15. Parameter Data Options Dialog Box

4. Use the radio buttons in the Parameter Data Options dialog box to select the parameters

Exporting Data
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you want to export and click OK. You may choose to export all parameters, or individual
parameter sets for wind, moisture, plants, soils and graphs.
5. In the File name text box enter a file name and click OK to save the data you selected in
the Parameter Data Options dialog box.
Note: Files you export may take a moment to appear in the Export and Import dialog
boxes. If you don’t see the file you have saved immediately, try clicking on the Look
in drop-down list to select another drive, and then click back to the original drive.

Exporting Data to a Remote Drive

For Account Holders working on a stand-alone copy of SimSphere or applet.
1. Choose File > Remote export.
Note: Menu items for which you do not have access will be grayed out.
2. In the Remote server export dialog box enter your user ID and password.
3. In the Name textbox type a file name at least eight characters long.
4. Click the Export options button to define the parameter data you want to export.
5. Use the radio buttons in the Parameter Data Options dialog box to select the parameters
you want to export and click OK.
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Exporting Data

8. Importing Parameter Data
You will use the import data commands to import, or open, files containing parameter data
created by you or another user. You can access the import data commands in the SimSphere File
drop-down menu and from specific parameter menus as described below.
Note: Your options for importing data will be determined by your user status and whether you
are accessing the tool as a stand-alone application or as an applet. Menu or tool bar items
for which you do not have access with be grayed out.



The notes that follow this computer symbol in the instructions below indicate the users
who have permission to access the SimSphere commands or features described.

Importing Data from a Local Drive

For Standard Users and Account Holders working on a stand-alone copy of SimSphere.
1. Create a new simulation.
Note: If you try to import, plant, soil, wind, moisture or graph data and you have not
already created a new simulation, a warning box will appear prompting you to
open a new one.
2. Choose File > Local Import or click the Local Import button on the tool bar.
Local Import button

The Import dialog box will appear.
Figure 16. Import Dialog Box

3. In the Import dialog box, click on the Look in drop-down list to choose the drive from
which you want to open a file.

Importing Data

31

4. Select the file you want to open from the display window in the Import dialog box.
5. To view the data in the file you have selected, click on the View XML file contents
button. Double click on the folders in the tree to view the data for the parameter of your
choice. Click OK to return to the Import dialog box.
6. Click the Open button.
7. Depending on the data you are importing, you will be given different options.
• Import Plant data

If you are importing plant data you will be given the choice to “add new plants to the
existing set, or replace existing set with new plants.”
 Select Add to add the data to the existing set of plants, or Replace to write over the
existing plant data set.
 Select Done to accept the changes or additions.
• Import Graphs

If you are importing graphs, the graph manager will appear immediately after the
import is completed.
 Work with the graphs as described in the section Graphing the Results of a Simulation in chapter 5, Graphing Results.

Importing Data from a Remote Drive

For Standard Users and Account Holders working on a stand-alone copy of SimSphere.
1. Create a new simulation.
Note: If you try to import, plant, soil, wind, moisture or graph data and you have not
already created a new simulation, a warning box will appear prompting you to
open a new one.
2. Choose File > Remote import.
3. In the Remote server import dialog box click import.
4. Select the file you wish to import.
5. Click view if you wish to view the data contained in the file before importing it.
Note: In addition to importing data using the commands from the File menu, you can access
those commands without leaving the individual parameter dialog boxes. See the
section which follows for help with this step.
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Importing Data from Surface, Vegetation, Moisture and Wind Sounding Parameter Dialog
Boxes

1.

Import data sets from the Parameter dialog boxes:
• In the Surface parameter window click on the Define soils button. In the Soils
dialog box click Import.
• In the Vegetation parameter window, select Define plants button. In the Plants
dialog box click Import.
• In the Moisture and Wind sounding, Plant and Soil parameter dialog boxes
click the Import button.

Figure 17. Soils Dialog Box

After clicking the Import button, the Import soil data pop-up box will appear.
Figure 18. Import Soil Data Dialog Box

2.

Importing Data

Choose to either import data from a local file or from a remote Internet location.
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3.

If you have a simulation open, SimSphere will now prompt you to export data
since the values in the parameter settings will be replaced by those that you import
from your local or remote file.

4.

Choose whether or not to export parameter data. For complete information on this
step, please refer to chapter 7, Exporting Parameter Data.

5.

Continue with the data import. For complete information on this step, please refer
to chapter 8, Importing Parameter Data.

Importing Data

9. Sample Simulation
To give you an idea of how you will be using SimSphere in your classwork, the instructions
below describe step by step how to work through simulation series 1 and 2 for Diurnal Variations of the Surface Turbulent Fluxes, chapter 1 of your text.

Simulation Series 1
Run Control Simulation with Default Parameters

I. Launch SimSphere

a. Run SimSphere as an application from a local machine.
b. Run SimSphere as an applet in a Web browser.
II. Create a New Simulation
III. Run Simulation
IV. Graph Results

1. Choose Graph > New Graph.
2. Click Add series.
3. Select Air temperature 10m (C) or Air temperature 50m (C) from the scrollable
“Choose a Series” list in the Add y-series window to add to the graph.
4. Leave series type as “static” and click Add.
5. Repeat the Add series process to add:
• sensible heat flux
• latent heat flux
• net radiation
VI. Name Graph*

Note: For more help with this step please see chapter 5, Graphing Results.
V. Adjust Graph Appearance*

1. Enlarge the graph window by clicking on the maximize window button.
2. Change the line color and style for each one of the series you have plotted.
3. Click OK to accept the changes.

Sample Simulation
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VII. Print graph*

Note: For more help with this step please see the section Printing graphs in chapter 5,
Graphing Results.
*

The steps marked with an asterisk are not required, but they may help you to store and
manage simulation results for later use.

Simulation Series 2
Change Simulation Latitude and Date

II. Edit data and latitude

1. Choose Parameter > Time/Location or click the Time/Location button on the toolbar.
2. Change the default date to October and the default latitude to 20°.
3. Click OK.
III. Graph Results

1. Choose Graph > New Graph
2. Add to graph the series:
• surface air temperature
• sensible heat flux
• latent heat flux
Choosing Dynamic or Static
If you choose “dynamic” in the Add Y-Series dialog box when you graph the series, you will be able to see
the results of the changes you have made in the parameters after running the simulation (described below).
For more on graphing dynamic series, please see the section by that name in chapter 5, Graphing Results.
If you would like to graph and export (save) the results of all three iterations of this simulation, proceed as
described below and plot the series as static lines.

IV. Edit Latitude

1. Choose Parameter > Time/Location or click the Time/Location button on the toolbar.
2. Change the latitude from 20° to 60°.
V. Run Simulation
VI. Graph Series

1. Choose Graph > New Graph
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2. Add to graph the series:
• surface air temperature
• sensible heat flux
• latent heat flux
VII. Name graph*
VIII. Adjust Graph Appearance*
IX. Save (Export) Parameters and Graphs*

Note: For help with this step, please see chapter 7, Exporting Data.
*

The steps marked with an asterisk are not required, but they may help you to store and
manage simulation results for later use.

Sample Simulation
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